Problems displaying Czech characters

Discussion in 'Website Feedback' started by flapcats, Feb 19, 2008.

  1. flapcats

    flapcats Member

    Hi there,

    Is anyone else having trouble viewing certain pages at the moment?
    The grammar section seems to be full of " ,,? " instead of diacritic marks etc.

    I have to switch it manually over to 'central european' on my browser for every page in both Firefox and Explorer. Other Czech sites have no trouble and locallingo was fine last week.

  2. flapcats

    flapcats Member

  3. Petr_B

    Petr_B Well-Known Member

    Works fine for me. I'm using FireFox internet browser and Czech MS Windows XP. Maybe it's somewhat related to this, forums were fixed (it behaved exactly the same way as you described) but LocalLingo still not (assuming LL is a part of MyCzechRepublic project)? But again, it can be a problem on your side, let's see if anyone else is experiencing the same issue.
  4. wer

    wer Well-Known Member

    No problem with both Opera and Firefox under Linux.

    The encoding in the head of the html file is correctly set to iso-8859-2, thus there should be no problem with automatic encoding.

    Maybe you set a fixed encoding, win cp1250 for example, and it does not work now with all Czech sites.

    There could be also problem with Central European fonts.

    Or maybe, you just did not notice it works fine now. (Try to refresh the page, the old version with wrong encoding could be cached in your browser’s history.)
  5. GlennInFlorida

    GlennInFlorida Well-Known Member

    works fine here too
  6. My Czech Republic

    My Czech Republic Administrator

    Thanks for letting us know about the issue you're having with the Czech characters. The character encoding was fixed on the boards and it should also be working correctly on Local Lingo.

    As wer suggested, could you try refreshing the page or clearing your browser cache and revisiting the page? Please post if it solved the problem or not.

  7. flapcats

    flapcats Member

    I'm on Linux here and the above page is still broken.
    It looks like this:

    -, (masculine)
    -, (feminine)
    -, (neuter)


    -ý (masculine)
    -á (feminine)
    -é (neuter)

    The first link seems to be good now though. It only started happening a week ago and no preferences have been changed (It'd be a bit of a coincidence that it started happening on 3 operating systems, 2 PCs and 2 browers!).

    Let me know if this page is broken still.
  8. eso

    eso Well-Known Member

    I see this page ok, but I looked into its code and header with definition of codepage is strange - codepage is defined twice:

    <meta http-equiv="Content-Language" content="en-us">
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2">
    <!-- #BeginEditable "doctitle" -->
    <meta http-equiv="Content-Language" content="en-us">
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2">

    Maybe that is problem.
  9. My Czech Republic

    My Czech Republic Administrator

    I went through all of our grammar pages and removed the double charset meta tag. I am running Windows XP SP2 and checked the pages in Firefox 2 and IE 6. The Czech characters displayed correctly for me on all the pages except for the Constructions with "aby" page where there were some missing Czech characters. That page is now been fixed.

    flapcats, I am not sure why the characters are not displaying correctly for you on that page. Can you check now that the double charset has been removed?

  10. flapcats

    flapcats Member

    Hey there,

    Looks like they're okay now. I'll post on this thread again if I see an incorrect page.

    Thanks a lot for fixing it!

Share This Page